Raspberry Pi3B: wie installiere ich wxPython?

Guten Tag,

Ich bin jetzt seit mehreren Tagen am Verzweifeln, wie ich das GUI-Paket "wxPython" installieren kann. Das Betriebssystem ist Raspbian (9 - "stretch") und Python ist mit der neuesten Version 3.6.4 installiert (sowie auch die vorinstallierte 2.7).

https://wiki.wxpython.org/BuildWxPythonOnRaspberryPi

Kaum ein Schritt dieser Anleitung funktioniert fehlerfrei, habe mich aber bis nach unten durchgekämpft, bestimmt um die 30 Abhängigkeiten manuell rausgesucht und installiert von anderen Seiten, aber es scheitert nach wie vor beim Build-Vorgang.

python3 build.py build bdist_wheel --jobs=1 --gtk2

Diese Zeile verursacht selbst nach allen Abhängigkeiten noch diesen Fehler:

sh: 1: /root/wxPython-4.0.1/ext/wxWidgets/configure: Permission denied
Error running configure
ERROR: failed building wxWidgets
Traceback (most recent call last):
 File "build.py", line 1295, in cmd_build_wx
  wxbuild.main(wxDir(), build_options)
 File "/root/wxPython-4.0.1/buildtools/build_wxwidgets.py", line 374, in main
  "Error running configure")
 File "/root/wxPython-4.0.1/buildtools/build_wxwidgets.py", line 85, in exitIfError
  raise builder.BuildError(msg)
buildtools.builder.BuildError: Error running configure

Allerdings verursacht eine, anscheinend wichtige, Abhängigkeit trotzdem einen Fehler bei der Installation:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:

 apt-get install gstreamer1.0

 gstreamer1.0-omx-dbg : Hängt ab von: gstreamer1.0-omx (= 1.0.0.1-0+rpi12+jessipmg) aber 1.10.4-1+rpt3 soll installiert werden

Linux
1 Antwort
Windows 10 bootet nur selten ?

Hallo zusammen!

ich habe das Notebook (Medion Akoya E7223T) einer Arbeitskollegin bekommen mit der Information, dass es nicht mehr läuft. Das Problem ist folgendes:

Im Normalfall, nach Einschalten des Notebooks, öffnet sich das BIOS-Menü. Unter Boot-Optionen findet man dann nur die Internetprotokolle IPv4 und IPv6, keinen Windows-Boots-Manager (also keine Festplatte).

Auffällig ist auch, dass die LED-Leuchte für die Festplatte nur kurz beim Starten aufleuchtet und danach nicht mehr. Dennoch taucht der Name der Festplatte im BIOS auf. Das Notebook hat zwei Steckplätze für Festplatten. Bei beiden das gleiche Problem (habs getestet).

Weiterhin habe ich den Arbeitsspeicher getestet und die Default Settings in den BIOS Einstellungen wiederhergestellt und die BIOS-Batterie einmal neu eingesetzt. Alles erfolgslos.

Meine Vermutung ist, dass die Festplatte keine Spannung bekommt, also ein Fehler im Netzteil oder im Mainboard.

Nun aber das komische: In seltenen Fällen nach Einschalten des Notebooks startet es Windows ganz normal und Windows läuft dann auch stabil ohne Abstürze oder ähnlichem. Es zeigt dann auch die Festplatte als Boot-Option im BIOS an.

Weiterhin ist mir aufgefallen, dass ich nichtmal USB-Mäuse oder Tastaturen anschließen kann, denn dann kommt es immer zur Fehlermeldung bei Windows Update (Fehler 0x80070002).

Ich würde ja Windows gerne neu installieren, ist aber schwierig wenn keine Festplatte erkannt wird...

Hat jemand eine Idee oder Ratschläge, woran das liegen könnte? Windows NT? Fehlende oder fehlerhafte Treiber? Oder ist es doch ein Hardware-Fehler?

Windows, software, Notebook, Hardware, Bios, Windows 10
1 Antwort
Pc geht nicht an, Mainboard und Netzteil bereits getauscht?

Hallo, wie gesagt geht mein Pc nicht an.

Er ging einfach letzten Samstag während ich ein Spiel spielte aus (war nebenbei ein super anspruchsloses Spiel).

Als ich den Pc wieder versuchte hochzufahren blieb der Bildschirm schwarz (keine Meldung, dass es kein Signal gäbe). Anfangs drehten sich noch alle Lüfter (Gehäuse Lüfter und LEDs am Netzteil, CPU Lüfter an CPU_FAN Header). Jedoch funktionierte nach dem 2. Startversuch der CPU Lüfter nicht mehr. Von jetzt auf gleich, genau so wie der PC ausgegangen ist - weg.

Als nächstes habe ich das Netzteil überbrückt - hat funktioniert. Baute es wieder ein, LEDs und Lüfter die daran angeschlossen waren gingen an. Nach 2-3 weiteren Startversuchen, als ich den Schalter des Netzteils auf die 1 umstellte um es anzumachen machte es ein *Puff* Geräusch und sprühte einen kleinen Funken (war ein BeQuiet Pure Power 9 400W). Habe es natürlich direkt danach ausgebaut und mit einem anderem 450W Netzteil (HKC® V-POWER 450W) ersetzt.

Jedoch auch nach dem Netzteil wechsel noch immer kein Bild und CPU Lüfter drehte sich auch nicht (Gehäuse Lüfter und LEDs funktionieren, da diese ans Netzteil angeschlossen sind).

Als es also auch nicht am Netzteil liegen konnte (ja ich bin mir sicher, dass es funktionieren müsste, da ich es neu gekauft habe) habe ich aufgrund des Tipps eines Freundes ein neues Mainboard gekauft, da er das selbe Problem gehabt zu haben schien. Demnach: neues Mainboard gekauft, eingebaut - PC geht nicht an.

Bevor ich jetzt noch mehr unnötige Teile kaufe: habt ihr Ideen woran das liegen könnte? An der CPU oder vielleicht an der Grafikkarte?

Und sollte ich das BeQuiet Netzteil jetzt besser nicht mehr benutzen, oder ist so ein Funken bei den Dingern nicht dramatisch?


Hier noch die Technischen Daten:

CPU: FX8350 (nicht übertaktet)

CPU Kühler: be quiet! Dark Rock 3

  1. Mainboard: 970A-G46
  2. Mainboard: GA-78LMT-USB3

GPU: Rx460 4GB

  1. Netzteil: BeQuiet Pure Power 9 400W
  2. Netzteil: HKC® V-POWER 450W


Grafikkarte, CPU, Computer
2 Antworten
Formatierung meiner zweiten SSD Festplatte?

Guten Tag,

Ich habe mir eine 2. SSD gekauft (Crucial mx500) und wollte diese nun in meinem PC (Windows 10) installieren. Ich habe sie eingebaut, eine neue Partition problemlos erstellt, jedoch funktioniert die Schnellformatierung auf NTFS nicht.

Ich hab es per DiskPart probiert und in der Datenträgerverwaltung, jedoch bleibt es in DiskPart auf 0% stehen und in der Datenträgerverwaltung wird im Status nur Formatierung angezeigt, jedoch nicht die Prozentanzahl wie weit die Formatierung ist. Ich dachte mir eventuell funktioniert ja die Normalformatierung, also habe ich kurzerhand diese per DiskPart gestartet und nach 45 minuten war die Formatierung bei 100%. Jedoch blieb sie bei 100% und wurde nicht abgeschlossen.

Ich habe die SSD danach auf Treiberupdates geprüft, Windowsupdates gesucht, sie mit Hilfe von Crucial Storage Executive überprüft, im System deaktiviert und wieder aktiviert, sie deinstalliert und wieder installiert, sie aus- und wieder eingebaut, doch nichts hat geholfen, das Problem blieb bestehen, die Schnellformatierung funktionierte überhaupt nicht und die Normalformatierung blieb bei 100% einfach stehen. Ich habe geprüft ob AHCI und TRIM aktiviert sind aber nichts hat geholfen, laut der Angaben ist mit der SSD alles im grünen Bereich, mit meinem System jedoch auch. Nun ist meine Frage ob es noch eine Möglichkeit gibt sie richtig zu formatieren oder ob ich die SSD umtauschen soll und es mit einer neuen versuchen soll

Festplatte, Formatierung, Formatieren, SSD
1 Antwort
Richtiger Laptop zur Videobearbeitung für YouTube?

Hallo Zusammen,

Wie schon in der Frage angemerkt suche ich einen neuen Laptop, da mein alter es nicht mehr bringt. In unterschiedlichen Foren habe ich mich schon belesen aber sehe den Wald vor lauter Bäumen nicht mehr und würde mich deshalb über präzise Vorschläge zu einzelnen Laptops freuen. Wichtig ist mir dabei wieso ihr den jeweiligen Laptop gewählt habt und bitte nicht mit fachchinesischen Bemerkungen mich noch mehr verwirren 😂

Jetzt zu meinen wichtigen Aspekten:

Wie schon gesagt würde ich Videobearbeitung betreiben wollen, präziser Vlogs für Youtube gestalten, wobei ich typische Sachen, wie Effekte, Überblendungen, Musik, vlt. auch Zeitraffer o.Ä. einbinden möchte. Die Videos werden mit einer gopro gefilmt und sollen dann mit 1080p60 hochgeladen werden.

Meine Überlegungen gehen dahin mit Shotcut als Freeware anzufangen und später dann auch Adobe Premiere pro zu nutzen.

Wichtig ist mir ein großer Bildschirm und mein Budget liegt zwischen 600 und 900 Euro.

Ich habe bei notebooksbilliger.fügehierschleichwerbungein mal nachgeschaut aber mehr als diese beiden Infos und dass er einen Arbeitsspeicher von 8GB haben soll, konnte ich keine weiteren Angaben machen, da z.B. die Ächtzigtrillionen verschiedenen Grafikkarten meinem Kopf nur aua gemacht haben.

Ich hoffe ihr könnt mir da weiter helfen und ich bedanke mich schon mal für jeden konstruktiven Kommentar 😁

Videobearbeitung, YouTube, Laptop, Videoschnitt, Vergleich
1 Antwort
USB für Windows 10 Installation lässt BIOS einfrieren?

Hallo, ich habe ein kleines Problem

Ich bin ein absoluter Noob was Computer undso angeht aber da mir öfters Mut gemacht wurde mir selber einen PC zusammen zu bauen, hab ich dies getan. Einige Komplikationen gabs aber als ich ihn das erste mal angeschaltet habe sah alles eigentlich ziemlich vielversprechend aus da alle Lüfter direkt angingen und die LEDs der Grafikkarte auch geleuchtet haben.

Jaa aber das wars auch. Kein Bild. Gar nichts. Ich habe nicht mal ein Piepen gehört, wobei ich nicht weiß ob das unbedingt so sein muss. Naja Stecker war richtig drin, auch den HDMI port habe ich versucht. Nichts. Mit dem Anschluss an der Grafikkarte hat es komischerweise direkt funktioniert. Naja hab mir da nicht viel gedacht und wollte erstmal Windows aufspielen. Da ich kein Laufwerk verbaut habe, habe ich mir im Internet einen bootfähigen USB-Stick mit Windows 10 drauf bestellt von dem ich das alles installieren wollte. Hab mir auch zahlreiche Videos dazu angeschaut und sah eigentlich auch ziemlich einfach aus. Naja das Problem ist nur dass der USB Stick alles zum einfrieren bringt. Ich bin mir nicht sicher ob es wirklich am USB liegt aber sobald ich ihn einstecke reagieren Maus und Tastatur nicht mehr und im BIOS bleibt die Zeit stehen. Sobald ich ihn allerdings wieder rausziehe kann ich alles wieder ganz normal benutzen. Habe natürlich alle USB Ports ausprobiert.

Liegt das jetzt wirklich nur am USB oder hab ich was falsch verkabelt oder ist vielleicht sogar das Mainboard defekt?

Ich verzweifel langsam weil das schon verdammt viel Geld war und ich jetzt nicht weiß woran es genau liegt.

Ich frage mich jetzt sogar ob es nicht besser gewesen wäre, wenn ich das mit dem PC einfach gelassen hätte.

Hier meine Komponenten für einen besseren Überblick:

Gehäuse: Cooler Master MasterBox 5 mit Sichtfenster KWNN 11 Midi Tower

Grafikkarte: 6GB Palit GeForce GTX 1060 JetStream Aktiv PCIe 3.0 x16 (Retail)

Netzteil: 400 Watt be quiet! Pure Power 10 CM Modular 80+ Silver

RAM: 16GB Corsair Vengeance LPX schwarz DDR4-3000 DIMM CL15 Dual Kit

Prozessor: AMD Ryzen 5 1600 6x 3.20GHz So.AM4 BOX

SSD: 275GB Crucial MX300 2.5" (6.4cm) SATA 6Gb/s 3D-NAND TLC Toggle (CT275MX300SSD1)

Festplatte: 1000GB Seagate BarraCuda ST1000DM010 64MB 3.5" (8.9cm) SATA 6Gb/s

Mainboard: ASRock Fatal1ty AB350 Gaming K4 AMD B350 So.AM4 Dual Channel DDR4 ATX Retail

Ich hoffe wirklich das jemand so nett ist und mir helfen kann :3

Grafikkarte, Hardware, Mainboard, USB, Windows 10
1 Antwort

Gute Fragen von heute

Beliebte Themen