Wie kann ich in Excel nur Werte von einem bestimmten Jahr ausgeben lassen?

5 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Das ist eine typische Aufgabe, die mit einer Pivot-Tabelle erledigt wird. Damit kannst du die Tabelle lassen wie sie ist und eine abhängige Pivot-Analyse draufsetzen. Die brauchst du dann nur noch aktualisieren. Die Anzahl und die Kilometer pro Jahr kämen sofort und ohne Anstrengung dabei heraus.

Als einzige Erweiterung würde ich eine weitere Spalte mit =Jahr(<datum>) einfügen, dann hast du es mit dem Pivot leichter.

Hi DrErika,

vielen Dank für Deine Info. Nur leider weiß ich überhaupt nicht was eine Pivot-Tabelle ist und hab somit auch noch nie etwas damit gemacht.

Das müsste doch auch über ne wenn/dann Formel zu regeln sein, oder? - schau Dir mal die Antwort von HWH001 und meinen Kommentar darunter an - vielleicht gibt es eine Lösung auf "herkömmlichem" Weg? - sollte doch für ein Programm wie Excel keine unlösbare Aufgabe stellen.... ist doch eigentlich ein ganz normaler "Standardwunsch"

0
@DrErika

Und: Ja, das geht auch mit Zählenwenn, Summewenn usw. - da hab ich nur grad keinen Spaß dran, weil es mit Pivot soviel einfacher geht.

0
@DrErika

Fügst du in Spalte 1 ein "=JAHR(B2)", kannst du in G1 2015, H1 2016 und I1 2017 eintragen. Dann kannst du mit den Formeln in G2: =SUMMEWENN($A:$A;G$1;$C:$C), H2: =SUMMEWENN($A:$A;H$1;$C:$C) und I2: =SUMMEWENN($A:$A;I$1;$C:$C) die jeweiligen Kilometersummen je Jahr errechnen lassen.

Darunter in G3, H3 und I3 könntest du mit =ZÄHLENWENN($A:$A;G$1), =ZÄHLENWENN($A:$A;H$1) und =ZÄHLENWENN($A:$A;I$1) die jeweilige Fahrtanzahl ermitteln.

Einfacher ist eine Pivot.

1
@DrErika

yep! vielen Dank! nach Deinem Hinweis heute mittag auf zählenwenn und summwenn hab ich's schon gebastelt :-) passt alles super! nur das mit dem Jahr wollte nicht in eine Formel - musste ich eben, wie Du ja geschrieben hast in einer separaten Spalte anlegen - also erst mal in einer Spalte das Jahr in ne Zahl umwandeln. Dachte nach dem Hinweis von HWH001 dass das auch mit in der Zählenwenn Formel ginge.

(also =SUMMEWENN($E$4:$E$3000;JAHR($E$3:$E$3000)=2014);$G$4:$G$3000)

oder aber =SUMMEWENN($E$4:$E$3000;JAHR=2014;$G$4:$G$3000)

aber haut so leider nicht hin. Aber mit der Krücke über die versteckte Spalte geht es. Frage mich allerdings WARUM es nicht in einer Formel geht....

Piviot schaue ich mir bei Gelegenheit mal an - aber einfacher als diese 2 Formeln zu tippen kann es doch eigentlich gar nicht sein, oder? - wenn ich da erst ne Tabelle anlegen muss?

Danke Dir :-)

0

Hallo allocigar78,

Einfacher Vorschlag/Anregung:

genau wie im Anhang/Bild die Zeilen und Spalten anlegen, dann eventuell entsprechend modifizieren/anpassen:

Spalte B formatieren als DATUM,

Spalte C, D und E formatieren als ZAHL mit 0 Kommastellen,

Formel für D3: =WENN(C3<>"";D2+1;0) beliebig weit runterziehen,

Formel für E3: =WENN(UND(JAHR(B3)=2014;C3<>"");C3;"") beliebig weit runterziehen,

Formel für C12: =WENN(UND(JAHR(B3)=2014;C3<>"");C3;"")

Formel für D12: =SUMME(E3:E11)

für eventuelle Rückfragen nochmals posten

Viel Spass

HWHOO1

 - (Excel, Formel, Datum)

Hallo HWH001,

vielen Dank für Deine Antwort. Deine Lösung ist am nächsten dran von dem was ich möchte, aber ganz so haut das noch nicht hin.

Bei Deiner Lösung müsste ich ja für jedes Jahr eine eigene versteckte Spalte anlegen.

Und die Summenformel nutzt mir natürlich nicht viel da ich ja nicht unter einer Spalte zusammenzählen will sondern die Spalte läuft ja weiter mit Einträgen auf dem nächsten Jahr usw.

Dein Bild mit Deiner Tabelle ist sehr gut um Dir zu erklären was ich möchte:

stell Dir vor in Feld B12 geht es jetzt einfach mit Einträgen aus dem Jahr 2015 weiter. Diese dürfen also für die Berechnung der Gesamt-Km 2014 nicht berücksichtigt werden.

In Feld A2 möchte ich jetzt die Gesamtkilometer für 2014 ausgegeben haben, in A3 die Anzahl der Fahrten, in A5 dann z. B. die Gesamt km für 2015 und in A6 die Anzahl der Fahrten für 2015 usw.

0

Und als Ergänzung: Die meisten derartigen Probleme lassen sich leichter angehen, wenn man von vornherein mit einem technisch logischen Datumsformat arbeitet. Also so, wie man in der Mathematik immer vorgeht, vom Großen zum Kleinen. Es muss nicht unbedingt das internationale Format sein, also "2015-07-21", auch 20150721 funktioniert ganz gut. Da aber Tabellenkalkulationsprogramme auf das internationale Datumsformat ausgelegt sind, ist dessen Verwendung natürlich ratsam.

Was möchtest Du wissen?