Excel zählenwenn Funktion - warum funktioniert das nicht mit 2 Bedingungen?

...komplette Frage anzeigen

3 Antworten

Die Formel von bubuc ist schon ok, das ist keine UND- sondern eine ODER-Bedingung.

Wenn du x und y zählen willst, dann ist folgendes möglich: =ZÄHLENWENN(A1:A8;"x")+ZÄHLENWENN(A1:A8;"y"). Das lässt sich auf die gleiche Weise auf andere Inhalte anpassen und erweitern.

Eine ODER-Bedingung innerhalb der ZÄHLENWENN-Funktion (wie du es versucht hast) ist vielleicht auch möglich, weiß ich jetzt aber nicht, wie. Meine Excel XP-Hilfe hilft da nicht weiter, vielleicht ist die Hilfe bei neueren Versionen besser?

hmm, franz, wie sollte es keine "und" bedingung sein? es werden doch die kriterien addiert.

aber ist eh nebensache, hauptsache ist, dass es funktioniert, ODER? ;-)

mit den leerzellen hatte ich schon etwas ärger um sie zusammenzukriegen...

schon lange habe ich mich damit nicht mehr ausseinandergesetzt.

0

yep! das ist es vermutlich! probiere ich aus! Danke!

0

es gibt noch 'ne möglichkeit, da viele wege führen nach rom:

=SUMME(ZÄHLENWENN(A1:A8;"x");ZÄHLENWENN(A1:A8;"y");ZÄHLENWENN(A1:A8;"z");ZÄHLENWENN(A1:A8;"xy");ZÄHLENWENN(A1:A8; "yz");ZÄHLENWENN(A1:A8; "xz");ZÄHLENWENN(A1:A8; "111"))

;-)

das könnte funktionieren! Yep, probiere ich, super! Danke Dir!

0
@bubuc

sorry, konnte nur eine HA auszeichnen und Franz27 hat die Lösung etwas eher geschrieben. Auf jeden fall hat's funktioniert. Vielen Dank noch mal.

0

nimm diese formel und werd' glücklich:

=ZÄHLENWENN(A1:A8;"x")+ANZAHLLEEREZELLEN(A1:A8)

das ist eine "und" nicht "oder" bedingung.

0
@bubuc

eine Und-Bedingung nutzt mir nichts - bei einer Und-Bdingung müssen ja beide bzw. alle Bedinungen erfüllt sein - ich möchte aber alle Felder die X haben gezählt haben und alle Felder die z. B. Y haben - das mit den leeren Zellen war ja nur ein Beispiel. Das heißt also Deine Lösung funktioniert nur, bei Leerzellen - wenn ich aber alle x und y suchen möchte funktioniert es nicht - gut ich kann natürlich zwei mal eine einzelne Formel schreiben und dann wieder aufaddieren lassen in einer dritten Formel - aber ich dachte halt, es geht vielleicht auch in einer Formel.

0
@allocigar78

also wie wär's wen du genau das fragst, was du auch haben willst?

woher sollte ich ahnen, was du alles zählen willst?

die leerzelle ist übrigens eine von den schwersten übungen für excel.

willst du alle zellen zusammenzählen die irgendeinen eintrag haben, so nimm die

anzahl2

funktion dazu. ist doch so beschißen einfach!

0
@bubuc

ich sagte doch, ich möchte 2 von x Werten zählen - nicht die gesamten Werte, die Anzahl2 zählen würde und auch nicht unbedingt Leerzellen. Ich habe z. B die Werte a, b, c, c, e , f und möchte die Werte e und f gezählt haben.

0

Was möchtest Du wissen?