Frage von Olivenbaum2013, 8

Wie rechne ich in excel mit Uhrzeiten?

Hallo,

die Grundlagen verstehe ich schon, eine Tabelle habe ich bereits erfolgreich erstellt: Aus von-Uhrzeiten und bis-Uhrzeiten erhalte ich Stunden, die ich dann über das 24-Stunden-Format addieren kann.

Mein Problem ist aber nun, dass ich ab und zu auch manuell eingefügte 'negative' Stunden habe. Die werden allerdings in der Summe nicht berücksichtigt. Warum? Hier meine Summen-Formell: =TEXT(ABS(E36-E33);WENN(E33<E36;"-";) &"h:mm")

Danke im Voraus

Antwort
von dkilli, 3

Beispiel:

In A1 steht Kommt B1 Geht C1 Ist D1 Soll

In E1 soll die Differenz stehen. Schreib in E1 =(D1-C1)24-1

Das Ergebnis ist die Zeit Dezimal dargestellt. Das bedeutet 1;30 wird zu 1,50 Da dabei 1 Std keine 60 min hat sondern 1 Std hat 100 Einheiten! Damit lässt sich ganz einfach rechnen. =SUMME(von:bis) Das Ergebnis ist die Zeit als Dezimalzahl. Jetzt muss diese Zahl wieder als Urzeit umgewandelt werden.

=WENN(E1<0;TEXT(E1*-1/24;"-hh:mm");E1/24)

Kommentar von dkilli ,
In E1 soll die Differenz stehen. Schreib in E1 =(D1-C1)24-1

Da fehlt das /

In E1 soll die Differenz stehen. Schreib in E1 =(D1-C1)/24-1

Antwort
von HWHOO1, 2

Hallo Olivenbaum2013,

hier gibt's eine Erklärung / Lösung für dieses Problem:

http://www.office-loesung.de/ftopic104655_0_0_asc.php

Grüsse,

HWH

Kommentar von Fugenfuzzi ,

Nicht vergessen auch die entsprechende Zellen zu Formatieren in das gewünschte Format das man haben will. Eines der vielen Leichtsinnigkeiten die auch Laien machen.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten