Frage von sotnu, 4

Kann es sein, dass meine GPU (GTX470) meine andere (GTX 960) ausbremst?

Also ich habe eingestellt, das die GTX 470 Die Pyhsix (oder wie die heissen, hald eben die Physik) berechnet, kann das sein, dass mir das die Spielperfomance nimmt ?

Weil ic hspiele gerade The Elder Scrolls Morrowind und ich habe da ein FPS Zähler drinn und der zeigt mir oftmals schlechte Werte an. Manchmal, wenn die Grafikkarte wahrscheinlich etwas berechnet, was mehr Rechenleistung erfordert, stockt es bei mir und zeigt dann (im Durchschnitt) 17-23 FPS an. Manchmal auch wenn ein neuer Abschnitt geladen wird, also ich meine damit nicht in ein neues Gebiet reinladen, sondern wenn die Sichtweite erweitert wird.

Ja und das Spiel ist ja (ca) von 2002 und da fände ich es schon ziemlich komisch wenn ich dann mit meiner GTX 960 und der GTX 470 ins stocken komme.

Wichtig zu erwähnen wäre evtl. auch noch, das ich die Sichtweite um das 3-Fache erweitert habe, aber (!) die Sichtweite ist im standart Modus so lächerlich, das es bei diesem Spiel eigentlich nicht viel ausmachen sollte. Wenn ich sie nicht erweitert hätte, dann hätte ich immer das Gefühl im Nebel zu laufen, weil die die Sicht so kurz ist :)

Auf 1920x1080 habe ich auch umgeschaltet. Aber mit diesen 2 ''Erweiterungen', sollte ein so altes spiel mit einer GTX 960 doch flüssig laufen, wenigsten immer 30 FPS, oder nicht ?

Könnte es sein das es wegen meiner GTX 470 irgendwie ausgebremst wird ?

Oder was könnte es sein?

Gruss sotnu

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von NerdyByNature, 3

Huhu sotnu,

ich persönlich würde keine zwei GraKas unterschiedlicher Bauarten betreiben. Aber das ist Gemschmackssache.

Wenn Du die alte GraKa einfach mal rausmachst, wie verhält es sich denn dann? Ich vermute stark, dass es dann sehr viel flüssiger laufen wird. Probier das doch mal aus, oder willst Du unbedingt die alte Grafikkarte mitnutzen?

Du hattest doch eine ähnliche Frage hier bereits gestellt und an der Antwort von Faron solltest Du erkannt haben, dass es zwar theoretisch geht, aber mit sehr viel Aufwand verbunden ist, daraus einen Schuh zu machen ;)

Also, raus damit und dann mal testen! Sag dann bitte Bescheid wie es läuft.

Lieben Gruß

Nerdy

Kommentar von sotnu ,

Danke für die Antwort.

Ok dann werd ich das mal machen. Muss ich sie komplett rausnehmen, oder reicht es, wenn ich die GTX960 wieder die PhysX berechnen zu lassen ?

Und ja, hab schon eine ähnliche Frage gestellt, aber irgendwie hat es sich für mich so angehört, das es helfen könnte, wenn ic hdie GTX 470 anschliesse.

Kommentar von NerdyByNature ,

Ich habe Farons Kommentar sehr aufmerksam gelesen (hoffe ich :D) fand das selbst sehr interessant. Ich hielt das einfach für eine neutrale Aussage über Möglichkeiten die Du hast und hatte das nicht als Empfehlung empfunden, dass Du das so machen solltest. Aber ich kann mich auch irren :D Da könnte der liebe Faron Licht ins Dunkel bringen. Es sollte ausreichen wenn Du zunächst sämtliche Funktionalitäten auf die 960 switcht, die Du auf die alte Karte gelegt hattest... Das Ausbauen kannst ja immernoch machen ;)

Kommentar von sotnu ,

Ok ich habe jetzt die PhysX auf die GTX 960 übertragen, es wäre aber auch die CPU als Auswahlmöglichkeit vorhanden.

Wirklich bemerkbar hat sich ncihts geändert, eigentlich ist es noch gleich. Ich habe jedoch was anderes getestet. Also bin im Spiel in eine äusserst dunkle Höhle gegangen und hatte da dann durchschnittlich immer 200FPS. Also muss es für die GTX 960 wohl doch sehr anstrengend sein dieses Spiel in Hd auflösung und 3-facher Sichtweite auszugeben.

Find ich komisch, da das spiel ja immerhin ca 13 Jahre alt ist und ich eine GTX 960 habe.

Aber ich Probier dann noch aus, die GTX470 ganz rauszunehmen, vielleicht ändert das ja was.

Denkst du (oder Faron), dass es ne gute Idee wäre die PyhsX auf die CPU zu übertragen ? oder soll ich es auf Standart stellen oder doch lieber auf GTX 960 lassen ?

Kommentar von FaronWeissAlles ,

Versuch es. Lass die CPU es machen, teste erneut. Gibts keine Änderung, spiele mit anderen Einstellungen herum und teste wieder. Wenn du eine Besserung bemerkst hast du einen Hinweis auf die Ursache des Problems. Muss ja nicht zwangsläufig PhysX sein...

Was hast du eigentlich für eine CPU / für RAM?

Kommentar von NerdyByNature ,

Ich würde die alte Karte ausbauen und dann testen wie es funzt. Wenn es dann nicht richtig funzt, dann liegt es an irgendwelchen Einstellungen. Da können wir dann immernoch rätseln ;)

Kommentar von sotnu ,

Ok, ich habe sie jetzt komplett rausgenommen und nochmals getestet.
Ich habe aber die PyhsX auf ''Automatisch auswählen (Empfohlen)'' eingestellt.

Also immer noch das selbe.

Wenn ich allerdings die Helligkeit in der Höle hochstelle, gehen die FPS runter (vermutlich weil vorher alles Schwarz war ^^). Und sobald ich die Höhle verlasse gehen die FPS auf 30 Runter und schwanken dann zwischen 17 und 30.

Wenn ich die Sichtweite mit dem Mausrad zurückstelle, sehe ich gleich wie die FPS höher werden. 

Wenn ein neuer Sichtbereich geladen wird (du weisst was ich meine oder?), ann sinken die FPS direkt auf 20 und je weiter ich dann laufe, desto höher werden sie, weil ich mich dann ja der 'Sichtgrenze' nähere und sobald dann wieder mehr dazu kommt, sinkt es wieder.

Wenn ich rückwärts laufe, sehe ich ja alles was geladen wurde und es kommt immer mehr dazu (beim Vorwärtslaufen ist es genau umgekehrt) und dann sinken die FPS stark, vorhin auf 8.

Also für mich sieht es schon so aus, als wäre die grosse Sichtweite (die aber eben garnicht so gross ist) dafür verantwortlich ist. Wirklcih komisch finde ich das, schliesslich ist das ein altes Spiel und meine Grafikkarte ist eigentlich ja eine der neusten und auch nicht schlecht.


Ich habe den i5 760 2.8 GHz und 8 GB Ram mit 1600MHz Taktrate.

Hat die Festplatte was damit zu tun, wenn ich neue Bereiche lade ? Eigentlich macht das ja zu 100% die Grafikkarte oder ?


Kommentar von sotnu ,

An den pyhsx liegt es glaub nicht, habe jetzt auch noch geteste indem ich der CPU diese Aufgabe übertragen habe, auch nicht besser.

Kommentar von NerdyByNature ,

Welche DirectX Version ist denn bei Dir am Laufen?

WINDOWSTASTE+R -> dxdiag

Ziemlich weit unten steht die Version!

Hast du die aktuellsten Treiber der Grafikkarten installiert? Hast Du den aktuellsten Patch für das Spiel?

Kommentar von sotnu ,

Ja die Treiber sind keine 10 Tage alt. Und ist DirectX 11.

Das Spiel ist wie gesagt etwa 13 Jahre alt und gibt keine neuen Patches mehr, also ja, ich habe die neuste Version.

Habe aber mit einem Programm (extra nur für dieses Spiel) die Auflösung und Sichtweite erhöt.

Normale Auflösung ist 12??x7?? (genau weiss ich gerade nicht) und ich habe sie in 1920x1080 hochgestellt. Die Sichtweite habe ich wie gesagt um das 3-fache erhöht. Habe aber kein AntiAlysing (oder wie es geschrieben wird) drinn und auch kein Schatten. Nur erhöte Auflösung und Sichtweite. Anscheinend ist das nicht 'nur'.

Kommentar von NerdyByNature ,

Schalte die dynamischen Schatten mal aus und schau dann wie es sich verhält... EInfach die Datei MGEXEgui.exe im Morrowind Verzeichnis öffnen und dort er pixel lighting / real time shadows deaktivieren. Könnte funktionieren.

Morrowind ist ein sehr altes Spiel, dass mit den ganzen tollen Features Deines Rechners wohl einfach nichts anzufangen weiß und deswegen sehr viel weniger Performance nutzen kann, als es Dein System hergäbe ;)

Kommentar von sotnu ,

Das gibt es bei mir nicht. MGE ist das Morrowind Graphic Extender ? Die Echtzeitschatten, habe ich gerade vorhin im Spiel direkt ausgeschaltet, das hat ein bisschen was gebracht, aber auch nur ein bisschen. 'er pixel lighting' kann ich somit nicht ändern.

Ich könnte den Morrowind Graphic Extender downloaden, da kann man mehr einstellen. Soll ich mal ?

Kommentar von NerdyByNature ,

Jupp... Einen Versuch ist es wert... Es liegt mit nahezu 100%iger Wahrscheinlichkeit nicht an den Grafikeinstellungen der Karten, sondern an denen des Spiels!

Kommentar von sotnu ,

Ok. Aber ich hab wie gesagt die Auflösung verändert, das kostet ja auch mehr Resourcen und die Sichtweite ist ja auch was, dass viel Resourcen kostet. Und die habe ich ja wie gesgt hoch gestellt.

Aber wäre schön wenn ich das so belassen könnte und etwas anderes das Problem ist.

Ich lade es runter, müsstest mir dann aber sagen was aktivieren und was nicht, ich gebe dann bescheid.

Kommentar von sotnu ,

Ok ist gemacht.

http://forum.worldofplayers.de/forum/threads/1004133-Morrowind-Graphics-Extender...

Bei diesem Link sind Bilder enthalten von diesem MGE und sieht genau so aus wie bei mir. Nur nicht das selbe ausgewählt. Ich habe kein AA oder AF. Bei mir ist nur 'Enable Fog' und 'Display Messages' unter 'Render State' aktiviert, unter 'Misc' ist  'Bind all distance to view distance' und unter 'morrowind.ini' ist 'Thread loading' und 'Hit Fader' aktiviert.

Kurz gesagt, alles so wie nach dem Download.

Kommentar von NerdyByNature ,

Im Morrowind.ini Fenster siehst Du eine Textdatei. Da steht irgendwo dann High detail shadows. Ist der Wert dazu 1? Wenn ja, dann gebe dort eine 0 ein um das zu deaktivieren!

Mach das mal, und wenn es dann immernoch nicht passt, dann schrauben wir weiter :D

Kommentar von sotnu ,

Ok das war nicht ausgewählt. Ich habe jetzt doch einfach mal die Sichtweite Reduziert . Hab sie jetzt um 150% erhöt, anstat um 200%. Anscheinend lag es wirklich an dem.

Die Fps sind bis jetzt bei der selben Aktion (rückwärts laufen bis man z.b den Berg weit weg nicht mehr sieht) nur noch auf 23 gefallen, anstatt 5^^.

Schade eigentlich, da ich jetzt wieder ein wenig 'Nebelsicht' habe.

Danke an euch beide, das ihr mir geholfen habt. Ich denke ich belasse es so, dass ich einfach die Sichtweite runterschraube. Schatten, AA und AF habe ich ja draussen, viel mehr geht ja nicht mehr, also muss ich das runterschrauben.

Antwort
von FaronWeissAlles, 2

Es gibt einen Weg das festzustellen - durch einen gezielten Benchmark.

Versuche zunächst die FPS Drops zu reproduzieren. Also eine Folge von Abläufen an bestimmten Orten im Spiel wo du immer auf die schlechten FPS triffst, Beispiel: Du stehst auf einem bestimmten Hügel, alles ist bestens, erhöhst die Sichtweite und schaust einmal im Kreis, deine FPS gehen dabei runter und du vermutest das liegt an PhysX auf der 470. Kann auch was anderes sein, irgend ein bestimmter Load-Trigger oder sowas, Hauptsache du machst immer das gleiche und kannst das Problem immer wieder reproduzieren.

Wenn du das hast, ändere die PhysX-Einstellungen. Dass die 960 die Berechnung übernimmt und teste erneut. Hast du dann auch Probleme? Falls nein, liegts tatsächlich an der Karte. Falls ja, kann es entweder an der Karte liegen (wenn die 960 mit der zusätzlichen Berechnung überfordert ist und deswegen auch die FPS einbrechen) oder es liegt an was anderem

Kommentar von sotnu ,

Also danke erstmal für die Antwort.

Was ein Load-Trigger ist, weiss ich nicht.

Wenn ich in die Ferne schaue, oder schnell drehe, dann gehen die FPS runter und eben wenn ich ein neuen Sichtbereich lade. Manchmal aber wie gesagt, einfach so beim Laufen (und nicht immer am selben Ort). Warum genau weiss ich nicht, irgendwas muss die Grafikkarte ja mehr Rechnen.

Manchmal stocken die NPC's auch von weitem am Anfang und wenn ich mich dann nähere gehts.

Und ok, ich werd dann mal das mit den PhysX Einstellungen machen.

Danke

Gruss sotnu

Kommentar von sotnu ,

Die Folgeantwort steht dann bei NerdyByNature, damit nicht alles doppelt steht.

Kommentar von NerdyByNature ,

Also ich wäre für den Thread von Faron gewesen... Der steht weiter oben :D Außerdem @Faron ... Das heißt nicht dass Du jetzt einfach aufhören darfst zu antworten... Ich brauche Dein Fachwissen hier :D

Kommentar von sotnu ,

Ja man kann es auch nach hier oben verlegen :)

Weisst du denn zufällig was ich da bei dem MGE anklicken soll ? Ich kenne da nicht alle Fachbegriffe.

Antwort
von capulio, 2

Vielleicht wird das Spiel automatisch mit der Grafikkarte GTX470 ausgeführt. Mach mal nen Rechtsklick auf die Anwendung und dann - "Mit Grafikprozessor ausführen"-GTX960

Keine passende Antwort gefunden?

Fragen Sie die Community